Write latencies to all affected Oso Cloud environments have recovered.
Posted Sep 22, 2025 - 22:11 UTC
Update
Over the next hour environments should see gradual recovery in write delays, with full recovery estimated in 2 hours.
Posted Sep 22, 2025 - 19:37 UTC
Update
We are continuing to monitor the replication recovery. Some affected customers should be seeing their workloads returning to normal, others should continue to see a reduction in write delay.
Posted Sep 22, 2025 - 18:01 UTC
Monitoring
We have identified an increase in delay in write processing for some customers. We have identified the source to be a backlog of writes in our processing queue, and a sequential bottleneck for some environments. The backlog of writes has completed processing and we are monitoring the replication lag as it returns to normal levels.
Posted Sep 22, 2025 - 16:57 UTC
This incident affected: Oso Cloud (Authorization APIs).