Stale reads in us-east-1

Incident Report for Oso

Postmortem


Resolved

The regional restart is complete. We continue to observe that reads are accurate.
Posted Jul 08, 2025 - 15:44 UTC

Monitoring

We have confirmed that all affected nodes are no longer in use and reads are no longer stale. We are continuing with the regional restart.
Posted Jul 08, 2025 - 14:35 UTC

Identified

We have identified that certain nodes stopped processing writes, which result in their returning stale results. We have replaced the affected nodes and are preemptively replacing all of the nodes in the region to remediate the issue.
Posted Jul 08, 2025 - 13:48 UTC